It is currently Mon Nov 20, 2017 7:53 am




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Is it broken?
PostPosted: Tue May 03, 2016 10:22 pm 
New member

Joined: Tue May 03, 2016 10:10 pm
Posts: 1
a few months ago I bought a used sp-555 from guitar center and only have just got to use it now. when i press the pads, the samples sound distorted and crackly. I've even tried using a mic and even sampling something from my turntable. all of it sounds distorted. I'm suspecting that this is an internal issue.

this is what it sounds like:

https://clyp.it/gwml4ddk

Is my sp-555 broken? what exactly is broken about it? is there any way to fix it?


Offline
 Profile  
Top 
 Post subject: Re: Is it broken?
PostPosted: Mon May 09, 2016 5:30 pm 
Member
User avatar

Joined: Thu Jan 12, 2012 3:51 am
Posts: 187
sounds crazy. Did you record all these samples via rca or mic in?

check all your cables. Check something else going into your soundcard input to make sure its not your soundcard too.

it sounds kinda like overdriving a mixer

_________________
http://www.soundcloud.com/kiyani
http://kiyani.bandcamp.com


Offline
 Profile  
Top 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 



Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: